INTERNET TEACHING LAB:  FRAME-RELAY LAB

Overview

 

In this lab, we will explore the frame-relay data link protocol.  Frame-relay is widely deployed by phone companies in wide area networks (WANs) and related to the X.25 and ATM protocols.  Routers or frame-relay access devices (FRADs) have a physical serial connection to a service provider’s nearest frame-relay switch typically across a T1 or digital data service (DDS) circuit.  Usually, the service provider will have several interconnected frame-relay switches depicted in diagrams as a cloud.  A state-wide service provider in Florida, for example, would typically have a frame-relay switch in each of Florida’s ten LATAs.  Since an end user data circuit to the nearest frame-relay switch would be intralata (will not cross a LATA boundary), the cost for the “local loop” is greatly reduced.  Within the frame network, permanent virtual circuits (PVCs) are created.  The PVC endpoints are identified by data link channel identifiers (DLCIs) represented by integers in the range [16..1007].  Although possible to build a full mesh of PVCs in the frame network, this is rarely done because there is usually a recurring cost associated with each PVC and with N nodes, the number of PVCs required, N(N-1)/2 becomes large quickly.  A more common configuration is a logical “hub-and-spoke” topology.  In this lab, r2 will be the hub, while r1, r3, and r4 will be spokes.  (Router r5 will not have a frame-relay connections because it has no serial WAN interfaces.)  Frame-relay switches also use a control protocol called the link management interface (LMI) used to inform routers what DLCIs are defined and their status. 

 

 

ASSIGNMENT:

 

In this lab, you will be given a partially broken router configuration with 3 problems that need to be identified and solved:

 

1.                  The frame-relay DLCIs by default are associated with the router physical interfaces but in this exercise need to be associated with the subinterfaces.  For example, on r4, the DLCI 402 should be associated with the multipoint subinterface Serial1/3.1 instead of physical interface Serial1/3.

2.                  Routers r1, r2, r3, and r4 all have their frame-relay interfaces addressed on the same 192.168.5.0/24 network, yet only some will be able to PING each other.  A protocol called “inverse arp” can automatically map frame-relay DLCI numbers to IP addresses, but the mapping will be incomplete because there is not a full mesh of PVCs.  You will find that R2 can PING the R1, R3, and R4 and they can PING R2, but that R1, R3, and R4 cannot PING each other.

3.                  Distance vector routing protocols like RIP normally do not advertise routes out an interface on which the route was learned.  This behavior is called “split horizon”.

 

Commands that may be helpful to debug this assignment:

 

-                     show frame-relay pvc

-                     show frame-relay lmi

-                     debug frame-relay events

-                     debug frame-relay packets

-                     show ip route

-                     show ip protocol

-                     show ip interface

-                     show frame-relay route (useful only on R2)

 

Hints:

 

Read up on the following commands in the Cisco manuals:

-                     frame-relay interface-dlci

-                     frame-relay map ip

-                     ip split-horizon

 

Even with the partially broken configuration given, you should see LMI or Link Management Interface messages on your router.  These are status messages where the frame-relay switch informs your router which DLCIs are defined and their status.  You can use the “show frame-relay lmi” command.  If set up correctly, you should see the number of status enquire messages sent incrementing, with an equal number of status messages received as shown below.

 

Good Luck!

 

r4#show frame-relay lmi

 

LMI Statistics for interface Serial1/3 (Frame Relay DTE) LMI TYPE = ANSI

  Invalid Unnumbered info 0             Invalid Prot Disc 0

  Invalid dummy Call Ref 0              Invalid Msg Type 0

  Invalid Status Message 0              Invalid Lock Shift 0

  Invalid Information ID 0              Invalid Report IE Len 0

  Invalid Report Request 0              Invalid Keep IE Len 0

  Num Status Enq. Sent 94818            Num Status msgs Rcvd 94818

  Num Update Status Rcvd 0              Num Status Timeouts 0

 

r

Router

Interface

IP Address

r1

Loopback0

192.168.11.1/24

 

ethernet2/0

192.168.10.1/24

 

ethernet2/1

192.168.20.1/24

 

ethernet2/2

192.168.30.1/24

 

ethernet2/3

192.168.40.1/24

 

ethernet2/4

192.168.50.1/24

 

ethernet2/5

192.168.60.1/24

 

serial1/3.1

192.168.5.1/24

r2

Loopback0

192.168.22.2/24

 

serial1/3.1

192.168.5.2/24

r3

Loopback0

192.168.33.3/24

 

serial1/0.1

192.168.5.3/24

 

serial1/6

192.168.36.3/24

r4

Loopback0

192.168.44.4/24

 

fddi0/0

192.168.45.4/24

 

serial1/3.1

192.168.5.4/24

r5

Loopback0

192.168.55.5/24

 

fastethernet0

192.168.70.1/24

 

ethernet0

192.168.80.1/24

 

ethernet1

192.168.90.1/24

 

fddi0

192.168.45.5/24

 


BROKEN ROUTER CONFIGURATION:

 


COMMON:

service udp-small-servers

service tcp-small-servers

enable password cisco

no ip domain-lookup

ip classless

ip subnet-zero

logging buffered

service timestamps debug datetime localtime

service timestamps log datetime localtime

clock timezone EST -5

clock summer-time EDT recurring

ntp server 192.168.66.6

snmp-server community public RO

line con 0

 exec-timeout 0 0

line aux 0

line vty 0 4

 password cisco

 login

 

R1:

hostname r1

interface E2/0

 description Vlan 10 to cat1 FA0/1

 ip address 192.168.10.1 255.255.255.0

 no shutdown

interface E2/1

 description Vlan 20 to cat1 FA0/2

 ip address 192.168.20.1 255.255.255.0

 no shutdown

interface E2/2

 description Vlan 30 to cat1 FA0/3

 ip address 192.168.30.1 255.255.255.0

 no shutdown

interface E2/3

 description Vlan 40 to cat1 FA0/4

 ip address 192.168.40.1 255.255.255.0

 no shutdown

interface E2/4

 description Vlan 50 to cat1 FA0/5

 ip address 192.168.50.1 255.255.255.0

 no shutdown

interface E2/5

 description Vlan 60 to cat1 FA0/6

 ip address 192.168.60.1 255.255.255.0

 no shutdown

interface loopback0

 ip address 192.168.11.1 255.255.255.0

 no shutdown

interface Serial1/3

 description Frame-Relay WAN

 encapsulation frame-relay IETF

 frame-relay lmi-type ansi

 no shutdown

interface Serial1/3.1 multipoint

 ip address 192.168.5.1 255.255.255.0

 no shutdown

router rip

 network 192.168.11.0

 network 192.168.10.0

 network 192.168.20.0

 network 192.168.30.0

 network 192.168.40.0

 network 192.168.50.0

 network 192.168.60.0

 network 192.168.5.0

 

R2:

hostname r2

interface loopback0

 ip address 192.168.22.2 255.255.255.0

 no shutdown

interface Serial1/3

 description Frame-Relay WAN

 encapsulation frame-relay IETF

 frame-relay lmi-type ansi

 no shutdown

interface Serial1/3.1 multipoint

 ip address 192.168.5.2 255.255.255.0

 no shutdown

router rip

 network 192.168.22.0

 network 192.168.5.0

 

R3:

hostname r3

frame-relay switching

interface loopback0

 ip address 192.168.33.3 255.255.255.0

 no shutdown

interface Serial1/0

 description Frame-Relay WAN

 encapsulation frame-relay IETF

 frame-relay lmi-type ansi

 no shutdown

interface Serial1/0.1 multipoint

 ip address 192.168.5.3 255.255.255.0

 no shutdown

interface Serial1/1

 description Frame-Relay port to R1 S1/3

 no ip address

 encapsulation frame-relay IETF

 clockrate 2000000

 frame-relay lmi-type ansi

 frame-relay intf-type dce

 frame-relay route 102 interface Serial1/2 201

 no shutdown

interface Serial1/2

 description Frame-Relay port to R2 S1/3

 no ip address

 encapsulation frame-relay IETF

 clockrate 2000000

 frame-relay lmi-type ansi

 frame-relay intf-type dce

 frame-relay route 201 interface Serial1/1 102

 frame-relay route 203 interface Serial1/3 302

 frame-relay route 204 interface Serial1/4 402

 no shutdown

interface Serial1/3

 description Frame-Relay port to R3 S1/0

 no ip address

 encapsulation frame-relay IETF

 clockrate 2000000

 frame-relay lmi-type ansi

 frame-relay intf-type dce

 frame-relay route 302 interface Serial1/2 203

 no shutdown

interface Serial1/4

 description Frame-Relay port to R4 S1/3

 no ip address

 encapsulation frame-relay IETF

 frame-relay lmi-type ansi

 frame-relay intf-type dce

 frame-relay route 402 interface Serial1/2 204

 no shutdown

!

interface serial1/6

 descr Serial link to R6 S1 toward Internet

 ip address 192.168.36.3 255.255.255.0

 no shutdown

router rip

 network 192.168.36.0

 network 192.168.33.0

 network 192.168.5.0

 

R4:

hostname r4

interface loopback0

 ip address 192.168.44.4 255.255.255.0

 no shutdown

interface fddi0/0

 descr Link to R5 FDDI0

 ip address 192.168.45.4 255.255.255.0

 no shutdown

interface Serial1/3

 description Frame-Relay WAN

 encapsulation frame-relay IETF

 frame-relay lmi-type ansi

 clock rate 2000000

 no shutdown

interface Serial1/3.1 multipoint

 ip address 192.168.5.4 255.255.255.0

 no shutdown

router rip

 network 192.168.44.0

 network 192.168.45.0

 network 192.168.5.0

 

R5:

hostname r5

interface FastEthernet0

 description Vlan70 to cat1 FA0/7

 ip address 192.168.70.1 255.255.255.0

 media-type 100BaseX

 no shutdown

interface Ethernet0

 description Vlan80 to cat1 FA0/8

 ip address 192.168.80.1 255.255.255.0

 media-type 10BaseT

 no shutdown

interface Ethernet1

 description Vlan90 to cat1 FA0/9

 ip address 192.168.90.1 255.255.255.0

 media-type 10BaseT

 no shutdown

interface Fddi0

 description Link to R4 FDDI0/0

 ip address 192.168.45.5 255.255.255.0

 no shutdown

interface loopback0

 ip address 192.168.55.5 255.255.255.0

 no shutdown

router rip

 network 192.168.70.0

 network 192.168.80.0

 network 192.168.90.0

 network 192.168.45.0

 network 192.168.55.0